Summary: This KB article describes how to deal with VXR238015.



Article Content

Issue


VxRail Manager cannot access ESXi host with the recorded management account information.

Error VXR238015
Cause
The management account password recorded in VxRail Manager for ESXi host is invalid.
Resolution
  1. If the new password is known, refer to step 8 to update the new host password to VxRail Manager. Otherwise, reset the host management password from the disconnected host using steps 2 - 7.
  2. Go to the disconnected host's ESXi via http://<disconnected-host-ip-or-hostname>/
  3. Log in with the root username and password.
  4. Click on Manage on the left top panel.
  5. On the right panel, select Security & users tab > Users on the left.
  6. Find the management account and select the Edit user tool on the tool bar.
  7. A popup window appears to enter the Password and Confirm password fields to create a new password. Enter the information and click Save.
  8. Update the new host password with VxRail Manager via RESTful api:   
curl -XPOST https://<VxM IP>/rest/vxm/v1/system/update-credential -d '{[\
{\
"component": "esxi",\
"hostname": "<disconnected host name>",\
"username": "<the management username>",\
"password": "<the new password>"\
}\
]}'